查看: 632|回复: 1

「MOD」teeworlds旧版服务器网络协议强制升级

[复制链接]
游戏昵称
cpera
所属战队
暂无
喜爱模式
暂无
注册登记  
8-19-2018
最后登录
8-22-2018

社区身份   Hammer
社区贡献   0 点

16

积分

68

子弹

3

武士刀

发表于 8-19-2018 11:40:00 | 显示全部楼层 |阅读模式
本帖最后由 cpera_ 于 2018-8-22 00:24 编辑

注:本patch仅可在linux下使用
补丁包下载链接
https://github.com/CreeperGo/fuck-fake
由于历史原因(以及teeworlds0.6网络协议设计问题)导致某不愿透露姓名的国外人士对全列表老版本服务器进行攻击。本补丁包可以强制旧版本服务器使用新的DDNET的连接握手机制(所有客户端都可一验证,DDNET自动进入,其他旧版客户端需要手动进服),防止源ip欺骗和connecting塞人攻击使用方法:将patch.so放到服务器目录,启动服务器使用LD_PRELOAD=./patch.so ./teeworlds_srv即可单客户端首次进服会有ip验证,验证通过提示This server is full。客户端1秒后自动重连即可进入游戏




欢迎来到Teeworlds 中国社区!
游客
请先登录
您需要登录后才可以回帖 登录 | 立即加入

本版积分规则

快速回复 返回顶部 返回列表